<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>Photos: Meet The Fiancee Of PGA Championship&#039;s Cameron Champ</title><style id="rocket-critical-css">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</style> <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">/* <![CDATA[ */ //<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]> /* ]]> */</script> <meta name="description" content="Meet the fiancee of PGA Championship contender Cameron Champ, who is surging up the leaderboard on Sunday night." /><link rel="canonical" href="https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Photos: Meet The Fiancee Of PGA Championship&#039;s Cameron Champ" /><meta property="og:description" content="Meet the fiancee of PGA Championship contender Cameron Champ, who is surging up the leaderboard on Sunday night." /><meta property="og:url" content="https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship" /><meta property="og:site_name" content="The Spun" /><meta property="article:publisher" content="https://www.facebook.com/thespundotcom/" /><meta property="article:author" content="https://www.facebook.com/andrewholleranspun/" /><meta property="article:section" content="Golf" /><meta property="article:published_time" content="2020-08-09T22:36:11+00:00" /><meta property="fb:app_id" content="647746892042636" /><meta property="og:image" content="https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-1024x683.jpg" /><meta property="og:image:secure_url" content="https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-1024x683.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="683" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Meet the fiancee of PGA Championship contender Cameron Champ, who is surging up the leaderboard on Sunday night." /><meta name="twitter:title" content="Photos: Meet The Fiancee Of PGA Championship&#039;s Cameron Champ" /><meta name="twitter:site" content="@TheSpun" /><meta name="twitter:image" content="https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441.jpg" /><meta name="twitter:creator" content="@andrewjholleran" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://thespun.com/#organization","name":"College Spun Media Inc.","url":"https://thespun.com/","sameAs":["https://www.facebook.com/thespundotcom/","https://www.instagram.com/thespundotcom/","https://www.linkedin.com/company/college-spun/","https://twitter.com/TheSpun"],"logo":{"@type":"ImageObject","@id":"https://thespun.com/#logo","url":"https://thespun.com/wp-content/uploads/2017/02/LOGOGOOD.png","width":190,"height":36,"caption":"College Spun Media Inc."},"image":{"@id":"https://thespun.com/#logo"}},{"@type":"WebSite","@id":"https://thespun.com/#website","url":"https://thespun.com/","name":"The Spun","publisher":{"@id":"https://thespun.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://thespun.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship#primaryimage","url":"https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441.jpg","width":2048,"height":1365,"caption":"PGA Championship's Cameron Champ on Sunday."},{"@type":"WebPage","@id":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship#webpage","url":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship","inLanguage":"en-US","name":"Photos: Meet The Fiancee Of PGA Championship&#039;s Cameron Champ","isPartOf":{"@id":"https://thespun.com/#website"},"primaryImageOfPage":{"@id":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship#primaryimage"},"datePublished":"2020-08-09T22:36:11+00:00","dateModified":"2020-08-09T22:36:11+00:00","description":"Meet the fiancee of PGA Championship contender Cameron Champ, who is surging up the leaderboard on Sunday night."},{"@type":"NewsArticle","@id":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship#article","isPartOf":{"@id":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship#webpage"},"author":{"@id":"https://thespun.com/#/schema/person/acbb1e7f0b07cef3ab9076eb161b9c5c"},"headline":"Photos: Meet The Fiancee Of PGA Championship&#8217;s Cameron Champ","datePublished":"2020-08-09T22:36:11+00:00","dateModified":"2020-08-09T22:36:11+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship#webpage"},"publisher":{"@id":"https://thespun.com/#organization"},"image":{"@id":"https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship#primaryimage"},"articleSection":"Golf","copyrightYear":"2020","copyrightHolder":{"@id":"https://thespun.com#organization"}},{"@type":["Person"],"@id":"https://thespun.com/#/schema/person/acbb1e7f0b07cef3ab9076eb161b9c5c","name":"Andrew Holleran","image":{"@type":"ImageObject","@id":"https://thespun.com/#authorlogo","url":"https://secure.gravatar.com/avatar/b160ed36cb7ccc5e411c19eae9470c9f?s=96&d=mm&r=g","caption":"Andrew Holleran"},"description":"Andrew Holleran is the managing editor at The Spun.","sameAs":["https://www.facebook.com/andrewholleranspun/","https://twitter.com/andrewjholleran"]}]}</script> <link rel="amphtml" href="https://thespun.com/more/golf/cameron-champ-fiancee-pga-championship/amp" /><meta name="generator" content="AMP for WP 0.9.98.9" /><link rel='dns-prefetch' href='//thespun.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel="alternate" type="application/rss+xml" title="The Spun &raquo; Feed" href="https://thespun.com/feed" /><link rel="alternate" type="application/rss+xml" title="The Spun &raquo; Comments Feed" href="https://thespun.com/comments/feed" /> <script id="Cookiebot" src="https://consent.cookiebot.com/uc.js" data-cbid="b13219b1-f274-43f5-aa22-155c3d9be59b" data-blockingmode="auto" data-framework="IAB1" type="text/javascript" data-georegions="{'region':'US-06','cbid':'4a133d3c-0aaa-4607-ad8b-e404561040cb'}" defer></script> <script async src="//js-sec.indexww.com/ht/p/188584-280818703310229.js"></script> <style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link data-minify="1" rel='preload' id='college-spun-css' href='https://thespun.com/wp-content/cache/min/1/wp-content/themes/collegespun/style-a1a257c1501866bc645da41eb67ee78a.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='college-spun-inline-css' type='text/css'>.mai-aec>.wrap:empty{display:none}.mai-aec>.wrap{margin-top:16px;margin-bottom:16px}.mai-aec-header-before>.wrap{padding-left:16px;padding-right:16px}.content .mai-aec>.wrap{padding-left:0;padding-right:0}.mai-aec>.wrap>p:last-child{margin-bottom:0}</style><link rel='preload' id='wp-block-library-css' href='https://thespun.com/wp-includes/css/dist/block-library/style.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='cspun-google-fonts-css' href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400italic%2C700%2C900&#038;ver=3.0.32' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.2/css/font-awesome.min.css?ver=4.6.2' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://thespun.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style> <script type='text/javascript' src='https://thespun.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <script type='text/javascript' src='https://thespun.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-migrate.min-1.4.1.js' defer></script> <link rel='https://api.w.org/' href='https://thespun.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thespun.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thespun.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.5" /><link rel='shortlink' href='https://thespun.com/?p=1016926' /><meta property="fb:pages" content="307711119272104" /><style>.getty.aligncenter{text-align:center}.getty.alignleft{float:none;margin-right:0}.getty.alignleft>div{float:left;margin-right:5px}.getty.alignright{float:none;margin-left:0}.getty.alignright>div{float:right;margin-left:5px}</style> <script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script> <script>!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
apstag.init({
    pubID: 'a85c3013-4cc8-497d-94e9-389ed61613f5',
    adServer: 'googletag',
    simplerGPT: true
});
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.cmd.push(function() {
var adunit1 = googletag.sizeMapping().
addSize([1075, 0], [[300, 600], [300, 250]]). //desktop
addSize([1024, 0], [[160, 600]]). //tablet
addSize([0, 0], [[0, 0]]). //mobile
build();
var adunit2 = googletag.sizeMapping().
addSize([2000, 0], [[728, 90], [320, 50], [1, 1]]). //desktopbigger
addSize([1025, 0], [[728, 90], [320, 50], [1, 1]]). //desktop
addSize([768, 0], [[728, 90], [320, 50], [1, 1]]). //iPad
addSize([481, 0], [[320, 50]]). //tablet
addSize([0, 0], [[320, 50], [1, 1]]). //mobile
build();
var adunit3 = googletag.sizeMapping().
addSize([1075, 0], [[300, 600], [300, 250]]). //desktop
addSize([1024, 0], [[160, 600]]). //tablet
addSize([0, 0], [[0, 0]]). //mobile
build();
var adunit4 = googletag.sizeMapping().
addSize([1024, 0], [[1, 1], [320, 50]]). //desktop
addSize([768, 0], [[1, 1], [320, 50]]). //tablet
addSize([0, 0], [[1, 1], [300, 250], [320, 50]]). //mobile
build();
var adunit5 = googletag.sizeMapping().
addSize([1024, 0], [[1, 1], [320, 50], [300, 250]]). //desktop
addSize([768, 0], [[1, 1], [320, 50], [300, 250]]). //tablet
addSize([0, 0], [[1, 1], [300, 250], [320, 50]]). //mobile
build();
var adunit6 = googletag.sizeMapping().
addSize([1025, 0], [[320, 50], [700, 250]]). //desktop
addSize([768, 0], [[300, 250], [320, 50]]). //tablet
addSize([0, 0], [[1, 1], [300, 250], [320, 50]]). //mobile
build();
var adunit7 = googletag.sizeMapping().
addSize([1075, 0], [[728, 90]]). //desktop
addSize([1024, 0], [[320, 50]]). //iPadPro
addSize([800, 0], [[728, 90]]). //tablet
addSize([0, 0], [[320, 50]]). //mobile
build();
 if (window.innerWidth > 1023) { googletag.defineSlot('/81469499/HeaderRightRailTop', [[300, 250], [300, 600], [160, 600]], 'div-gpt-ad-1469714874611-1').defineSizeMapping(adunit1).addService(googletag.pubads()); }
 if (document.getElementById("smartbanner-ad")) { googletag.defineSlot('/81469499/HeaderSmartBanner', [[1, 1], [320, 50], [728, 90]], 'div-gpt-ad-1469714874611-2').defineSizeMapping(adunit2).addService(googletag.pubads()); }
 if (window.innerWidth > 1023) { googletag.defineSlot('/81469499/HeaderRightRail2', [[300, 250], [300, 600], [160, 600]], 'div-gpt-ad-1469714874611-3').defineSizeMapping(adunit3).addService(googletag.pubads()); }
 if (document.getElementById("paragraph-3-ad")) { googletag.defineSlot('/81469499/HeaderAfter3Paragraphs', [[600, 300], [300, 250], [320, 50], [1, 1]], 'div-gpt-ad-1469714874611-4').defineSizeMapping(adunit4).addService(googletag.pubads()); }
 if (document.getElementById("before-entry-ad")) { googletag.defineSlot('/81469499/HeaderBeforeContent', [[1, 1], [300, 250], [320, 50]], 'div-gpt-ad-1469714874611-5').defineSizeMapping(adunit5).addService(googletag.pubads()); }
 if (document.getElementById("paragraph-6-ad")) { googletag.defineSlot('/81469499/HeaderAfter7Paragraphs', [[300, 250], [1, 1], [320, 50]], 'div-gpt-ad-1469714874611-6').defineSizeMapping(adunit6).addService(googletag.pubads()); }
 if (document.getElementById("after-entry-content-ad")) { googletag.defineSlot('/81469499/HeaderAfterContent', [[320, 50], [1, 1], [728, 90]], 'div-gpt-ad-1469714874611-7').defineSizeMapping(adunit7).addService(googletag.pubads()); }
googletag.pubads().setTargeting("url", "golf");
googletag.pubads().disableInitialLoad();
googletag.pubads().enableSingleRequest(); googletag.enableServices(); });
googletag.cmd.push(function(){ 
 apstag.fetchBids({ 
 timeout: 2000 }, 
   function(bids) {
     apstag.setDisplayBids(); 
     googletag.pubads().refresh();
 }); 
});</script> <script src="https://users.api.jeeng.com/users/domains/5OW6r3jJ2L/sdk/"></script> <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">/* <![CDATA[ */ //<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["golf"],"pagePostAuthor":"Andrew Holleran"};
	dataLayer.push( dataLayer_content );//]]> /* ]]> */</script> <meta name="google-site-verification" content="kFes6yxrCaJMLdoqdpt0fZiSfZbY2-TskFociiuG74Q" /> <script type="text/javascript" src="//d3btgdnq1vg0et.cloudfront.net/script.js" defer></script> <meta name="ahrefs-site-verification" content="a3595eb3f231cff8ae03a2fa3d0a0ced397ff2fd7cf431481c6b73bf444d7c16"><meta property="fb:pages" content="1412460009003133"><meta property="fb:pages" content="1110838148974057"><meta property="fb:pages" content="1565582760407628"><meta property="fb:pages" content="1718238971756970"><meta property="fb:pages" content="1169204429776926"><meta property="fb:pages" content="307711119272104"><meta property="fb:pages" content="487862754712073"><meta property="fb:pages" content="734088770029953"><meta property="fb:pages" content="1474695942805916"><meta property="fb:pages" content="206268596251139"><meta property="fb:pages" content="736129996406722"><meta property="fb:pages" content="712969492057690"><meta property="fb:pages" content="279914902167429"><meta property="fb:pages" content="1409441982646937"><meta property="fb:pages" content="423733604436750"><meta property="fb:pages" content="687883467921598"><meta property="fb:pages" content="648144291906890"><meta property="fb:pages" content="672056106166732"><meta property="fb:pages" content="1452533494978454"><meta property="fb:pages" content="593180180764356"><meta property="fb:pages" content="1385972475008109"><meta property="fb:pages" content="1393145820955433"><meta property="fb:pages" content="1392525091017947"><meta property="fb:pages" content="1377375672536508"><meta property="fb:pages" content="597649656980361"><meta property="fb:pages" content="515940788518481"><meta property="fb:pages" content="638808226173999"><meta property="fb:pages" content="676108209113864"><meta property="fb:pages" content="1401582656769398"><meta property="fb:pages" content="1399655283631249"><meta property="fb:pages" content="1468426270039345"><meta property="fb:pages" content="1421865521394325"><meta property="fb:pages" content="1474801576076481"><meta property="fb:pages" content="216299671901966"><meta property="fb:pages" content="672130512828289"><meta property="fb:pages" content="827887027227641"><meta property="fb:pages" content="682975038431191"><meta property="fb:pages" content="1399191543678416"><meta property="fb:pages" content="547819275316498"><meta property="fb:pages" content="268788526614771"><meta property="fb:pages" content="592758124134638"><meta property="fb:pages" content="562246977216877"><meta property="fb:pages" content="287098264771048"><meta property="fb:pages" content="1109249149124372"><meta property="fb:pages" content="636962073132407"><meta property="fb:pages" content="1607045872928088"><meta property="fb:pages" content="847736411993251"><meta property="fb:pages" content="533605593496437"><meta property="fb:pages" content="1076031099184010"><meta property="fb:pages" content="334839183521804"><meta property="fb:pages" content="1009957799073579"><meta property="fb:pages" content="1003120093120327"><meta property="fb:pages" content="1671577759825164"><meta property="fb:pages" content="322518931425785"><meta property="fb:pages" content="1719696458291599"><meta property="fb:pages" content="531612907033297"><meta property="fb:pages" content="495452747319946"><meta property="fb:pages" content="1587073968261411"><meta property="fb:pages" content="286667641715989"><meta property="fb:pages" content="181282148968628"><meta property="fb:pages" content="210769099450478"> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NRXCWXT');</script> <link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" /><link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" /><link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" /><link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" /><link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" /><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" /><link rel="apple-touch-icon-precomposed" sizes="57x57" href="/apple-touch-icon-57x57-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="60x60" href="/apple-touch-icon-60x60-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="/apple-touch-icon-72x72-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="76x76" href="/apple-touch-icon-76x76-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="/apple-touch-icon-114x114-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="/apple-touch-icon-120x120-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="/apple-touch-icon-144x144-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="/apple-touch-icon-152x152-precomposed.png" /><link rel="apple-touch-icon-precomposed" sizes="180x180" href="/apple-touch-icon-180x180-precomposed.png" /><link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" /><link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" /><link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" /><link rel="icon" type="image/png" href="/favicon-128.png" sizes="128x128" /><link rel="icon" type="image/png" href="/favicon-196x196.png" sizes="196x196" /><meta name="application-name" content="The Spun" /><meta name="msapplication-TileColor" content="#ffffff" /><meta name="msapplication-square70x70logo" content="mstile-70x70.png" /><meta name="msapplication-TileImage" content="mstile-144x144.png" /><meta name="msapplication-square150x150logo" content="mstile-150x150.png" /><meta name="msapplication-wide310x150logo" content="mstile-310x150.png" /><meta name="msapplication-square310x310logo" content="mstile-310x310.png" /><link rel="icon" href="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-100x100.png" sizes="32x32" /><link rel="icon" href="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-300x300.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-300x300.png" /><meta name="msapplication-TileImage" content="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-300x300.png" /><style type="text/css" id="wp-custom-css">p{font-size:17px}#smartbanner-ad{-webkit-transform:translateZ(0);-webkit-backface-visibility:hidden;-webkit-perspective:1000;left:0;position:fixed;text-align:center;bottom:0;width:100%;z-index:999}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-1016926 single-format-standard content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden no-js"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://thespun.com/">The Spun</a></p><p class="site-description">What&#039;s trending in the sports world today.</p></div><div class="widget-area header-widget-area"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><nav class="nav-header"><ul id="menu-primary-nav" class="menu genesis-nav-menu js-superfish"><li id="menu-item-333904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333904"><a href="https://thespun.com/category/nfl"><span>NFL</span></a></li><li id="menu-item-333901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333901"><a href="https://thespun.com/category/college-football"><span>College Football</span></a></li><li id="menu-item-333903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333903"><a href="https://thespun.com/category/nba"><span>NBA</span></a></li><li id="menu-item-333908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333908"><a href="https://thespun.com/category/college-hoops"><span>College Hoops</span></a></li><li id="menu-item-451373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-451373"><a href="https://thespun.com/category/more/interviews"><span>Interviews</span></a></li><li id="menu-item-327514" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-327514"><a href="https://thespun.com/what-is-college-spun"><span>About</span></a></li></ul></nav></div></section></div></div></header><div id="search-box" style="display:none;"><div class="wrap"><p class="search-desc">Search The Spun ...</p><form class="search-form" method="get" action="https://thespun.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://thespun.com/?s={s}"></form> <a class="search-close" href="#"><span class="screen-reader-text">Close</span><span class="fa fa-times" aria-hidden="true"></span></a></div></div><div class="site-inner"><div class="mai-aec mai-aec-header-after"><div class="wrap"><div id="smartbanner-ad"><div id="div-gpt-ad-1469714874611-2"><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-2'); });</script></div></div></div></div><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-1016926 post type-post status-publish format-standard has-post-thumbnail category-golf entry"><header class="entry-header"><p class="entry-meta"><span class="entry-meta-left"><time class="entry-time">August 9, 2020 @ 6:36pm</time><span class="entry-author"> » <a href="https://thespun.com/author/aholleran" class="entry-author-link" rel="author"><span class="entry-author-name">Andrew Holleran</span></a></span></span></p><h1 class="entry-title">Photos: Meet The Fiancee Of PGA Championship&#8217;s Cameron Champ</h1></header><div class="entry-content"><div class="featured-image" style="max-width:800px;text-align:center;margin:0 auto;"><img width="775" height="465" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20775%20465'%3E%3C/svg%3E" class="attachment-featured size-featured wp-post-image" alt="PGA Championship&#039;s Cameron Champ on Sunday." 0="itemprop" 1="image" data-lazy-srcset="https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-775x465.jpg 775w, https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-380x228.jpg 380w" data-lazy-sizes="(max-width: 775px) 100vw, 775px" data-lazy-src="https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-775x465.jpg" /><noscript><img width="775" height="465" src="https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-775x465.jpg" class="attachment-featured size-featured wp-post-image" alt="PGA Championship&#039;s Cameron Champ on Sunday." 0="itemprop" 1="image" srcset="https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-775x465.jpg 775w, https://thespun.com/wp-content/uploads/2020/08/GettyImages-1264895441-380x228.jpg 380w" sizes="(max-width: 775px) 100vw, 775px" /></noscript><span class="caption">SAN FRANCISCO, CALIFORNIA - AUGUST 09: Cameron Champ of the United States lines up a putt on the fifth hole during the final round of the 2020 PGA Championship at TPC Harding Park on August 09, 2020 in San Francisco, California. (Photo by Tom Pennington/Getty Images)</span></div><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><html><body><p>Cameron Champ is surging up the leaderboard at the PGA Championship on Sunday evening.</p><div class="mai-aec mai-aec-entry-content"><div class="wrap"><div id="before-entry-ad"><div id="after-entry-content-ad"><div id="div-gpt-ad-1469714874611-5"><script type="text/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-5'); });</script></div></div></div></div></div><p>The 25-year-old golfer might be in line for his first major championship win today. Champ is now -10 for the tournament, tied with Dustin Johnson for the lead. He&rsquo;s -2 through eight holes on Sunday in San Francisco.</p><p>Champ, a California native, has two career PGA Tour wins. His best finish at a major tournament came in 2017, when he finished tied for 32nd at the U.S. Open. That mark should be cleared by a wide margin today.</p><p>It could be a celebratory evening for the Champ group. Cameron and his longtime girlfriend got engaged earlier this year.</p><div class="mai-aec mai-aec-entry-content"><div class="wrap"><div id="paragraph-3-ad"><div id="div-gpt-ad-1469714874611-4"><script type="text/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-4'); });</script></div></div></div></div><p>&ldquo;<span class="">It&rsquo;s OFFICIAL!! &#10084;&#65039; You&rsquo;re the woman of my dreams, my best friend, and my biggest supporter! I wouldn&rsquo;t want to spend my life with anyone else but you!&rdquo; Champ wrote in December.&nbsp;</span></p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B59Es_Rl_NX/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B59Es_Rl_NX/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewbox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></p></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B59Es_Rl_NX/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">It&rsquo;s OFFICIAL!! &#10084;&#65039; You&rsquo;re the woman of my dreams, my best friend, and my biggest supporter! I wouldn&rsquo;t want to spend my life with anyone else but you!&#128141;</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/cameron__champ/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Cameron Champ</a> (@cameron__champ) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-12-12T01:40:29+00:00">Dec 11, 2019 at 5:40pm PST</time></p></div></blockquote><p><script async src="//www.instagram.com/embed.js"></script></p><div class="mai-aec mai-aec-entry-content"><div class="wrap"><div id="paragraph-6-ad"><div id="div-gpt-ad-1469714874611-6"><script type="text/javascript">googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-6'); });</script></div></div></div></div><p>&ldquo;Happy Birthday babe! Love you more than you know and I&rsquo;m extremely grateful to have you in my life. November 2020 can&rsquo;t come sooner!&rdquo; he wrote in April.</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B_YennzldwV/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B_YennzldwV/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewbox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></p></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B_YennzldwV/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Happy Birthday babe! Love you more than you know and I&rsquo;m extremely grateful to have you in my life. November 2020 can&rsquo;t come sooner! &#10084;&#65039;</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/cameron__champ/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Cameron Champ</a> (@cameron__champ) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-04-24T23:43:24+00:00">Apr 24, 2020 at 4:43pm PDT</time></p></div></blockquote><p><script async src="//www.instagram.com/embed.js"></script></p><p>Champ has consistently paid tribute to his partner on Instagram.</p><p>&ldquo;Appreciation day always! Thank you for being you! You&rsquo;re the most loving, caring and thoughtful person I know. I wouldn&rsquo;t know what to do without you in my life, we&rsquo;ve been on many adventures so far but I can&rsquo;t wait for the many more to come! I love you!!&rdquo; he wrote.</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B4gVThdFowu/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B4gVThdFowu/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewbox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></p></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B4gVThdFowu/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Appreciation day always! Thank you for being you! You&rsquo;re the most loving, caring and thoughtful person I know. I wouldn&rsquo;t know what to do without you in my life, we&rsquo;ve been on many adventures so far but I can&rsquo;t wait for the many more to come! I love you!!&#10084;&#65039;</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/cameron__champ/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Cameron Champ</a> (@cameron__champ) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-11-06T01:16:11+00:00">Nov 5, 2019 at 5:16pm PST</time></p></div></blockquote><p><script async src="//www.instagram.com/embed.js"></script></p><p>The final round of the PGA Championship is airing on CBS.</p><p>Will Champ be able to pull out his first major win?</p> <noscript><link data-minify="1" rel='stylesheet' id='college-spun-css'  href='https://thespun.com/wp-content/cache/min/1/wp-content/themes/collegespun/style-a1a257c1501866bc645da41eb67ee78a.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://thespun.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='cspun-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400italic%2C700%2C900&#038;ver=3.0.32' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.2/css/font-awesome.min.css?ver=4.6.2' type='text/css' media='all' /></noscript></body></html><div class="mai-aec mai-aec-after-entry-content"><div class="wrap"><div id="div-gpt-ad-1469714874611-7"><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-7'); });</script></div><p><script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/collegespun/loader.js',
  'tb_loader_script');</script></p><div id="taboola-below-article-thumbnails"></div><p><script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });</script><br /> <script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({flush: true});</script></p></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://thespun.com/category/more/golf" rel="category tag">Golf</a></span></p></footer></article><section class="author-box"><img alt="" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20200%20200'%3E%3C/svg%3E" class="avatar avatar-200" height="200" width="200" data-lazy-src="https://thespun.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-14-at-9.52.23-AM-150x140.png" /><noscript><img alt="" src="https://thespun.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-14-at-9.52.23-AM-150x140.png" class="avatar avatar-200" height="200" width="200"/></noscript><div class="author-box-content-wrap"><h4 class="author-box-title">About <span itemprop="name">Andrew Holleran</span></h4><div class="author-box-content" itemprop="description"><p>Andrew Holleran is the managing editor at The Spun.</p><div class="author-social"><a target="_blank" class="author-icon author-twitter" href="https://twitter.com/andrewjholleran"><span class="fa fa-twitter"></span></a><a target="_blank" class="author-icon author-facebook" href="https://www.facebook.com/andrewholleranspun/"><span class="fa fa-facebook"></span></a></div></div></div></section></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Search The Spun Here</h3><form class="search-form" method="get" action="https://thespun.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-2">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://thespun.com/?s={s}"></form></div></section><section id="cspun_popular_posts-2" class="widget widget_cspun_popular_posts"><div class="widget-wrap"><h3 class="widgettitle widget-title">What&#8217;s Trending</h3><ul"><li><a class="swPopularity" href="https://thespun.com/nba/toronto-raptors/kendrick-perkins-thinks-nba-got-coach-of-the-year-wrong">Kendrick Perkins Thinks NBA Got Coach Of The Year Wrong</a></li><li><a class="swPopularity" href="https://thespun.com/big-ten/minnesota/rashod-bateman-skipping-2020-season">Big Ten Football Star Announces He&#8217;s Skipping The 2020 Season</a></li><li><a class="swPopularity" href="https://thespun.com/big-ten/ohio-state-buckeyes/ohio-state-football-announces-teams-7-captains">Ohio State Football Announces Team&#8217;s 7 Captains</a></li><li><a class="swPopularity" href="https://thespun.com/big-ten/penn-state-nittany-lions/penn-state-micah-parsons-opt-out-2020">Penn State LB Michah Parsons Is Reportedly Opting Out Of 2020 Season</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/nfc-south/carolina-panthers/teddy-bridgewater-uses-1-word-to-describe-replacing-cam-newton">Teddy Bridgewater Uses 1 Word To Describe Replacing Cam Newton</a></li></ul></div></section><section id="mai_aec_widget_a-3" class="widget widget_mai_aec_widget_a"><div class="widget-wrap"><div class="mai-aec mai-aec-widget-b"><div id="div-gpt-ad-1469714874611-1"><script type='text/javascript'>if (window.innerWidth > 1023) {
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-1'); });
}</script></div></div></div></section><section id="featured-post-6" class="widget featured-content featuredpost"><div class="widget-wrap"><h3 class="widgettitle widget-title">More Trending</h3><article class="post-1015973 post type-post status-publish format-standard has-post-thumbnail category-college-football category-michigan-wolverines category-ohio-state-buckeyes category-top-stories category-trending entry"><a href="https://thespun.com/big-ten/michigan-wolverines/jalen-rose-makes-prediction-for-ohio-state-michigan" class="alignnone" aria-hidden="true" tabindex="-1"><img width="300" height="190" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20190'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Jalen Rose pictured at an event." data-lazy-srcset="https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-300x190.jpg 300w, https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-150x95.jpg 150w, https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-768x488.jpg 768w, https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-1024x650.jpg 1024w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-300x190.jpg" /><noscript><img width="300" height="190" src="https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-300x190.jpg" class="entry-image attachment-post" alt="Jalen Rose pictured at an event." srcset="https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-300x190.jpg 300w, https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-150x95.jpg 150w, https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-768x488.jpg 768w, https://thespun.com/wp-content/uploads/2020/06/GettyImages-1040551764-1024x650.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://thespun.com/big-ten/michigan-wolverines/jalen-rose-makes-prediction-for-ohio-state-michigan">Jalen Rose Makes Prediction For Ohio State vs. Michigan</a></h4></header></article><article class="post-1015915 post type-post status-publish format-standard has-post-thumbnail category-top-stories category-trending category-wrestling entry"><a href="https://thespun.com/more/wrestling/a-former-wwe-star-may-have-just-confessed-to-murder-on-facebook" class="alignnone" aria-hidden="true" tabindex="-1"><img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="entry-image attachment-post" alt="A picture of the WWE Belt." data-lazy-srcset="https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-300x200.jpg 300w, https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-150x100.jpg 150w, https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-768x511.jpg 768w, https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-1024x682.jpg 1024w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-300x200.jpg" /><noscript><img width="300" height="200" src="https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-300x200.jpg" class="entry-image attachment-post" alt="A picture of the WWE Belt." srcset="https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-300x200.jpg 300w, https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-150x100.jpg 150w, https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-768x511.jpg 768w, https://thespun.com/wp-content/uploads/2018/05/GettyImages-587852012-1024x682.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://thespun.com/more/wrestling/a-former-wwe-star-may-have-just-confessed-to-murder-on-facebook">A Former WWE Star May Have Just Confessed To Murder On Facebook</a></h4></header></article></div></section><section id="mai_aec_widget_b-2" class="widget widget_mai_aec_widget_b"><div class="widget-wrap"><div class="mai-aec mai-aec-widget-b"><div id="div-gpt-ad-1469714874611-3"><script type='text/javascript'>if (window.innerWidth > 1023) {
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-3'); });
}</script></div></div></div></section><section id="cspun_popular_posts-3" class="widget widget_cspun_popular_posts"><div class="widget-wrap"><h3 class="widgettitle widget-title">More Trending</h3><ul"><li><a class="swPopularity" href="https://thespun.com/nfl/nfc-west/seattle-seahawks/seahawks-released-2-veteran-nfl-players-sunday">The Seahawks Released 2 Notable Veteran Players On Sunday</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/nfc-east/new-york-giants/video-of-saquon-barkleys-insane-pool-jump-is-going-viral">Video Of Saquon Barkley&#8217;s Insane Pool Jump Is Going Viral</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/afc-north/pittsburgh-steelers/pittsburgh-steelers-stephon-tuitt-wont-kneel-national-anthem-protest-colin-kaepernick">Steelers Player Announces He Won&#8217;t Kneel For National Anthem</a></li><li><a class="swPopularity" href="https://thespun.com/more/mlb/a-temporary-decision-on-the-marlins-season-has-been-made">A &#8216;Temporary&#8217; Decision On The Marlins&#8217; Season Has Been Made</a></li><li><a class="swPopularity" href="https://thespun.com/nba/houston-rockets/rockets-eric-gordon-ankle-injury-update">Video: Rockets Star Eric Gordon Suffers Apparent Ankle Injury</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/afc-east/new-york-jets/new-york-jets-running-back-has-retired-at-24">New York Jets Running Back Has Retired At 24</a></li><li><a class="swPopularity" href="https://thespun.com/more/mlb/los-angeles-dodgers-houston-astros-punishment-suspension-joe-kelly-dave-roberts-dusty-baker">MLB Announces Punishment For Astros, Dodgers</a></li><li><a class="swPopularity" href="https://thespun.com/more/top-stories/mike-golic-honest-comment-mike-greenberg">Mike Golic Shares Honest Comment On Former Co-Host Mike Greenberg</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/nfc-west/seattle-seahawks/jamal-adams-reveals-his-plan-with-the-seahawks">Jamal Adams Reveals His &#8216;Plan&#8217; With The Seahawks</a></li><li><a class="swPopularity" href="https://thespun.com/nba/charles-barkley-has-message-for-critics-of-those-who-stand-for-anthem">Charles Barkley Has Message For Critics Of Those Who Stand For Anthem</a></li></ul></div></section></aside></div></div><nav class="nav-secondary" aria-label="Secondary"><div class="wrap"><ul id="menu-footer-nav" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-198365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198365"><a href="https://thespun.com/privacy-policy"><span>Privacy Policy / Terms Of Use</span></a></li><li id="menu-item-345159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-345159"><a href="https://thespun.com/coverage-by-team"><span>Coverage By Team</span></a></li></ul></div></nav><footer class="site-footer"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2020 <a href="https://thespun.com">The Spun</a> · All Rights Reserved · Powered by <a href="https://bizbudding.com/showcase/thespun/" target="_blank" rel="nofollow noopener">BizBudding Inc.</a></p></div></footer></div><nav id="side-menu" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><button class="menu-close" role="button" aria-pressed="false"><span class="fa fa-times" aria-hidden="true"></span> Close</button><form class="search-form" method="get" action="https://thespun.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-3">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-3" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://thespun.com/?s={s}"></form><div class="menu-primary-nav-container"><ul id="menu-primary-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333904"><a href="https://thespun.com/category/nfl">NFL</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333901"><a href="https://thespun.com/category/college-football">College Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333903"><a href="https://thespun.com/category/nba">NBA</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333908"><a href="https://thespun.com/category/college-hoops">College Hoops</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-451373"><a href="https://thespun.com/category/more/interviews">Interviews</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-327514"><a href="https://thespun.com/what-is-college-spun">About</a></li><li class="menu-item search"><a id="search-btn" class="search-btn"><span class="screen-reader-text">Search</span><span class="fa fa-search" aria-hidden="true"></span></a></li></ul></div><div class="menu-footer-nav-container"><ul id="menu-footer-nav-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198365"><a href="https://thespun.com/privacy-policy">Privacy Policy / Terms Of Use</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-345159"><a href="https://thespun.com/coverage-by-team">Coverage By Team</a></li></ul></div></nav><div id="side-posts"><button class="menu-close" role="button" aria-pressed="false"><span class="fa fa-times" aria-hidden="true"></span> Close</button><ul><li class="side-posts-date">August 09, 2020</li><li class="side-post"><div class="side-post-time">2 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/top-stories/wwe-star-passed-away-70" title="Beloved Former WWE Star Has Passed Away At 70">Beloved Former WWE Star Has Passed Away At 70</a></div></li><li class="side-post"><div class="side-post-time">27 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/golf/video-collin-morikawa-dropped-top-pga-championship-trophy" title="Video: Collin Morikawa Dropped The Top Of PGA Championship Trophy">Video: Collin Morikawa Dropped The Top Of PGA Championship Trophy</a></div></li><li class="side-post"><div class="side-post-time">42 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/golf/paige-spiranac-reacts-collin-morikawas-pga-championship-win" title="Paige Spiranac Reacts To Collin Morikawa&#8217;s PGA Championship Win">Paige Spiranac Reacts To Collin Morikawa&#8217;s PGA Championship Win</a></div></li><li class="side-post"><div class="side-post-time">1 hour ago</div><div class="side-post-title"><a href="https://thespun.com/college-football/justin-fields-reports-big-ten-canceling-the-season" title="Justin Fields Reacts To Reports Of Big Ten Canceling The Season">Justin Fields Reacts To Reports Of Big Ten Canceling The Season</a></div></li><li class="side-post"><div class="side-post-time">1 hour ago</div><div class="side-post-title"><a href="https://thespun.com/college-football/everyone-same-reaction-college-football-rumors" title="Everyone Has The Same Reaction To The College Football Rumors">Everyone Has The Same Reaction To The College Football Rumors</a></div></li><li class="side-post"><div class="side-post-time">1 hour ago</div><div class="side-post-title"><a href="https://thespun.com/more/golf/collin-morikawa-girlfriend-pga-championship" title="Photos: Meet The Girlfriend Of PGA Star Collin Morikawa">Photos: Meet The Girlfriend Of PGA Star Collin Morikawa</a></div></li><li class="side-post"><div class="side-post-time">2 hours ago</div><div class="side-post-title"><a href="https://thespun.com/more/golf/paige-spiranac-reacts-whats-happening-pga-championship" title="Paige Spiranac Reacts To What&#8217;s Happening In The PGA Championship">Paige Spiranac Reacts To What&#8217;s Happening In The PGA Championship</a></div></li><li class="side-post"><div class="side-post-time">2 hours ago</div><div class="side-post-title"><a href="https://thespun.com/acc/clemson-tigers/trevor-lawrence-reacts-to-college-football-on-brink-of-cancelation" title="Trevor Lawrence Reacts To College Football On Brink Of Cancelation">Trevor Lawrence Reacts To College Football On Brink Of Cancelation</a></div></li><li class="side-post"><div class="side-post-time">2 hours ago</div><div class="side-post-title"><a href="https://thespun.com/big-ten/everyone-has-the-same-message-for-the-big-ten-right-now" title="Everyone Has The Same Message For The Big Ten Right Now">Everyone Has The Same Message For The Big Ten Right Now</a></div></li><li class="side-post"><div class="side-post-time">2 hours ago</div><div class="side-post-title"><a href="https://thespun.com/more/golf/pga-championship-playoff-rules-tiebreaker-works" title="PGA Championship Playoff Rules: Here&#8217;s How A Winner Is Decided">PGA Championship Playoff Rules: Here&#8217;s How A Winner Is Decided</a></div></li><li class="side-post"><div class="side-post-time">2 hours ago</div><div class="side-post-title"><a href="https://thespun.com/nfl/afc-north/baltimore-ravens/ravens-on-verge-of-signing-veteran-nfl-running-back" title="Ravens On Verge Of Signing Veteran NFL Running Back">Ravens On Verge Of Signing Veteran NFL Running Back</a></div></li><li class="side-post"><div class="side-post-time">2 hours ago</div><div class="side-post-title"><a href="https://thespun.com/nfl/nfc-south/tampa-bay-buccaneers/tom-brady-bucs-helmet-visor" title="Photos: Tom Brady Unveiled A New Look At Practice Today">Photos: Tom Brady Unveiled A New Look At Practice Today</a></div></li></ul></div> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NRXCWXT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "31752891" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript> <img src="https://sb.scorecardresearch.com/p?c1=2&c2=31752891&cv=2.0&cj=1" /> </noscript><center><button onclick="javascript:CookieConsent.renew();CookieDeclaration.SetUserStatusLabel();">California Privacy Rights</button></center><script type='text/javascript' src='https://thespun.com/wp-content/cache/busting/1/wp-includes/js/hoverIntent.min-1.8.1.js' defer></script> <script type='text/javascript' src='https://thespun.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/menu/superfish.min-1.7.10.js' defer></script> <script type='text/javascript' src='https://thespun.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/skip-links.min-3.3.2.js' defer></script> <script type='text/javascript' src='https://thespun.com/wp-content/cache/busting/1/wp-content/themes/collegespun/assets/js/jquery.sidr.min-2.2.1.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var cspun_global_vars = {"side_posts_count":"87","side_posts_title":"New Articles","single_post":"1"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://thespun.com/wp-content/cache/min/1/wp-content/themes/collegespun/assets/js/global-6bef6a41ef142623e7b2ecb68471e51a.js' defer></script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://thespun.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script><noscript><link data-minify="1" rel='stylesheet' id='college-spun-css'  href='https://thespun.com/wp-content/cache/min/1/wp-content/themes/collegespun/style-a1a257c1501866bc645da41eb67ee78a.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://thespun.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='cspun-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400italic%2C700%2C900&#038;ver=3.0.32' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.2/css/font-awesome.min.css?ver=4.6.2' type='text/css' media='all' /></noscript></body></html>
