<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Browns, Baker Mayfield&#039;s Reps Met At The NFL Combine</title><style id="rocket-critical-css">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</style>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<meta name="description" content="According to a new report, the Browns confirmed their commitment to Baker Mayfield during a meeting with the quarterback&#039;s reps on Thursday." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Browns, Baker Mayfield&#039;s Reps Met At The NFL Combine" />
<meta property="og:description" content="According to a new report, the Browns confirmed their commitment to Baker Mayfield during a meeting with the quarterback&#039;s reps on Thursday." />
<meta property="og:url" content="https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine" />
<meta property="og:site_name" content="The Spun" />
<meta property="article:publisher" content="https://www.facebook.com/thespundotcom/" />
<meta property="article:author" content="https://www.facebook.com/MattHladikCS/?fref=ts" />
<meta property="article:tag" content="Baker Mayfield" />
<meta property="article:section" content="Cleveland Browns" />
<meta property="article:published_time" content="2022-03-03T22:11:25+00:00" />
<meta property="fb:app_id" content="647746892042636" />
<meta property="og:image" content="https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-1024x633.jpg" />
<meta property="og:image:secure_url" content="https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-1024x633.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="633" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="According to a new report, the Browns confirmed their commitment to Baker Mayfield during a meeting with the quarterback&#039;s reps on Thursday." />
<meta name="twitter:title" content="Browns, Baker Mayfield&#039;s Reps Met At The NFL Combine" />
<meta name="twitter:site" content="@TheSpun" />
<meta name="twitter:image" content="https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378.jpg" />
<meta name="twitter:creator" content="@matthladik919" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://thespun.com/#organization","name":"College Spun Media Inc.","url":"https://thespun.com/","sameAs":["https://www.facebook.com/thespundotcom/","https://www.instagram.com/thespundotcom/","https://www.linkedin.com/company/college-spun/","https://twitter.com/TheSpun"],"logo":{"@type":"ImageObject","@id":"https://thespun.com/#logo","inLanguage":"en-US","url":"https://thespun.com/wp-content/uploads/2017/02/LOGOGOOD.png","width":190,"height":36,"caption":"College Spun Media Inc."},"image":{"@id":"https://thespun.com/#logo"}},{"@type":"WebSite","@id":"https://thespun.com/#website","url":"https://thespun.com/","name":"The Spun","inLanguage":"en-US","description":"What&#039;s trending in the sports world today.","publisher":{"@id":"https://thespun.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://thespun.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine#primaryimage","inLanguage":"en-US","url":"https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378.jpg","width":2048,"height":1265,"caption":"Cleveland Browns quarterback Baker Mayfield."},{"@type":"WebPage","@id":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine#webpage","url":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine","name":"Browns, Baker Mayfield&#039;s Reps Met At The NFL Combine","isPartOf":{"@id":"https://thespun.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine#primaryimage"},"datePublished":"2022-03-03T22:11:25+00:00","dateModified":"2022-03-03T22:11:25+00:00","description":"According to a new report, the Browns confirmed their commitment to Baker Mayfield during a meeting with the quarterback's reps on Thursday.","potentialAction":[{"@type":"ReadAction","target":["https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine"]}]},{"@type":"NewsArticle","@id":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine#article","isPartOf":{"@id":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine#webpage"},"author":{"@id":"https://thespun.com/#/schema/person/a56d4c48090eacabb5aa6d201fe33101"},"headline":"Browns, Baker Mayfield&#8217;s Reps Met At The NFL Combine","datePublished":"2022-03-03T22:11:25+00:00","dateModified":"2022-03-03T22:11:25+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine#webpage"},"publisher":{"@id":"https://thespun.com/#organization"},"image":{"@id":"https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine#primaryimage"},"keywords":"Baker Mayfield","articleSection":"Cleveland Browns,Top Stories","inLanguage":"en-US","copyrightYear":"2022","copyrightHolder":{"@id":"https://thespun.com/#organization"}},{"@type":["Person"],"@id":"https://thespun.com/#/schema/person/a56d4c48090eacabb5aa6d201fe33101","name":"Matt Hladik","image":{"@type":"ImageObject","@id":"https://thespun.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/1a7e8bc9bcf9681a3467f91beab21c07?s=96&d=mm&r=g","caption":"Matt Hladik"},"description":"Matt is an Editor at The Spun Media.","sameAs":["https://www.facebook.com/MattHladikCS/?fref=ts","https://twitter.com/matthladik919"]}]}</script>

<link rel="amphtml" href="https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine/amp" /><meta name="generator" content="AMP for WP 1.0.68.1" /><link rel='dns-prefetch' href='//thespun.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Spun &raquo; Feed" href="https://thespun.com/feed" />
<link rel="alternate" type="application/rss+xml" title="The Spun &raquo; Comments Feed" href="https://thespun.com/comments/feed" />



<script>
		// GDPR Stub file.
	    ! function () { var e = function () { var e, t = "__tcfapiLocator", a = [], n = window; for (; n;) { try { if (n.frames[t]) { e = n; break } } catch (e) { } if (n === window.top) break; n = n.parent } e || (!function e() { var a = n.document, r = !!n.frames[t]; if (!r) if (a.body) { var i = a.createElement("iframe"); i.style.cssText = "display:none", i.name = t, a.body.appendChild(i) } else setTimeout(e, 5); return !r }(), n.__tcfapi = function () { for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++)n[r] = arguments[r]; if (!n.length) return a; if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) { var i = { gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub" }; "function" == typeof n[2] && n[2](i) } else a.push(n) }, n.addEventListener("message", (function (e) { var t = "string" == typeof e.data, a = {}; try { a = t ? JSON.parse(e.data) : e.data } catch (e) { } var n = a.__tcfapiCall; n && window.__tcfapi(n.command, n.version, (function (a, r) { var i = { __tcfapiReturn: { returnValue: a, success: r, callId: n.callId } }; t && (i = JSON.stringify(i)), e.source.postMessage(i, "*") }), n.parameter) }), !1)) }; "undefined" != typeof module ? module.exports = e : e() }();
	</script>
<script>
		// CCPA Stub file.
		(function () { var e = false; var c = window; var t = document; function r() { if (!c.frames["__uspapiLocator"]) { if (t.body) { var a = t.body; var e = t.createElement("iframe"); e.style.cssText = "display:none"; e.name = "__uspapiLocator"; a.appendChild(e) } else { setTimeout(r, 5) } } } r(); function p() { var a = arguments; __uspapi.a = __uspapi.a || []; if (!a.length) { return __uspapi.a } else if (a[0] === "ping") { a[2]({ gdprAppliesGlobally: e, cmpLoaded: false }, true) } else { __uspapi.a.push([].slice.apply(a)) } } function l(t) { var r = typeof t.data === "string"; try { var a = r ? JSON.parse(t.data) : t.data; if (a.__cmpCall) { var n = a.__cmpCall; c.__uspapi(n.command, n.parameter, function (a, e) { var c = { __cmpReturn: { returnValue: a, success: e, callId: n.callId } }; t.source.postMessage(r ? JSON.stringify(c) : c, "*") }) } } catch (a) { } } if (typeof __uspapi !== "function") { c.__uspapi = p; __uspapi.msgHandler = l; c.addEventListener("message", l, false) } })();
	</script>
<script>
		window._sp_ = {
			config: {
				accountId: 1178,
	 			baseEndpoint: 'https://cdn.privacy-mgmt.com',
				targetingParams: {
					type: "GDPR"
				}
			}
		}
		window._sp_ccpa = {
			config: {
				mmsDomain: "https://message.sp-prod.net",
				ccpaOrigin: "https://ccpa-service.sp-prod.net",
				accountId: 1178,
				getDnsMsgMms: true,
				alwaysDisplayDns: false,
				targetingParams: {
					type: "CCPA"
				}
			}
		}
	</script>
<script src="https://cdn.privacy-mgmt.com/wrapperMessagingWithoutDetection.js"></script>
<script src="https://ccpa.sp-prod.net/ccpa.js"></script>
<script async src="//js-sec.indexww.com/ht/p/188584-280818703310229.js"></script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link data-minify="1" rel='preload' href='https://thespun.com/wp-content/cache/min/1/wp-content/themes/collegespun/style-5d005c448b860c4bfcfd84c75fb15e77.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<style id='college-spun-inline-css' type='text/css'>

		.mai-aec > .wrap:empty {
			display: none;
		}
		.mai-aec > .wrap {
			margin-top: 16px;
			margin-bottom: 16px;
		}
		.mai-aec-header-before > .wrap {
			padding-left: 16px;
			padding-right: 16px;
		}
		.content .mai-aec > .wrap {
			padding-left: 0;
			padding-right: 0;
		}
		.mai-aec > .wrap > p:last-child {
			margin-bottom: 0;
		}
	
</style>
<link rel='preload' href='https://thespun.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.8' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link rel='preload' href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400italic%2C700%2C900&#038;ver=3.0.34&#038;display=swap' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<link data-minify="1" rel='preload' href='https://thespun.com/wp-content/cache/min/1/font-awesome/4.6.2/css/font-awesome.min-1365f7632c20556688c027d02ede560a.css' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://thespun.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://thespun.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://thespun.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thespun.com/wp-json/wp/v2/posts/1244584" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thespun.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thespun.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5.8" />
<link rel='shortlink' href='https://thespun.com/?p=1244584' />
<meta property="fb:pages" content="307711119272104" /> <style>
        .getty.aligncenter {
            text-align: center;
        }
        .getty.alignleft {
            float: none;
            margin-right: 0;
        }
        .getty.alignleft > div {
            float: left;
            margin-right: 5px;
        }
        .getty.alignright {
            float: none;
            margin-left: 0;
        }
        .getty.alignright > div {
            float: right;
            margin-left: 5px;
        }
        </style>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["cleveland-browns","top-stories"],"pagePostAuthor":"Matt Hladik"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script type="text/javascript">
  if (typeof $igniter_var === "undefined") {
    !function n(t,c,r,o,a,i,s,e,f,l,u){l=null!=t[r]&&"function"==typeof t[r].now?t[r].now():null,t.$igniter_var=i,t[i]=t[i]||function(){(t[i].q=t[i].q||[]).push(arguments)},e=c.getElementsByTagName(o)[0],(f=c.createElement(o)).async=1,f.setAttribute("charset","UTF-8"),"//cdn"==a?(t[i].s=l,f.onerror=function(e){t[i].e=e,n(t,c,r,o,a+"-fallback",i,s)}):t[i].r=l,(u=!t.Promise||!t.MutationObserver||!Object.assign)||(t[i].v="nbc"+(0<=a.indexOf("-fallback")?"f":"")),f.src=a+".petametrics.com/"+s+(u?"":"-nbc")+".js?ts="+(+new Date/216e5|0),e.parentNode.insertBefore(f,e)}(window,document,"performance","script","//cdn","$p","999gba4qphtjrmpe");
    $p("init", "999gba4qphtjrmpe");
    $p("send", "pageview");
  }
</script>
<meta name="google-site-verification" content="kFes6yxrCaJMLdoqdpt0fZiSfZbY2-TskFociiuG74Q" />
<script type="text/javascript" src="//d3btgdnq1vg0et.cloudfront.net/script.js"></script>
<meta name="ahrefs-site-verification" content="a3595eb3f231cff8ae03a2fa3d0a0ced397ff2fd7cf431481c6b73bf444d7c16">
<meta property="fb:pages" content="1412460009003133">
<meta property="fb:pages" content="1110838148974057">
<meta property="fb:pages" content="1565582760407628">
<meta property="fb:pages" content="1718238971756970">
<meta property="fb:pages" content="1169204429776926">
<meta property="fb:pages" content="307711119272104">
<meta property="fb:pages" content="487862754712073">
<meta property="fb:pages" content="734088770029953">
<meta property="fb:pages" content="1474695942805916">
<meta property="fb:pages" content="206268596251139">
<meta property="fb:pages" content="736129996406722">
<meta property="fb:pages" content="712969492057690">
<meta property="fb:pages" content="279914902167429">
<meta property="fb:pages" content="1409441982646937">
<meta property="fb:pages" content="423733604436750">
<meta property="fb:pages" content="687883467921598">
<meta property="fb:pages" content="648144291906890">
<meta property="fb:pages" content="672056106166732">
<meta property="fb:pages" content="1452533494978454">
<meta property="fb:pages" content="593180180764356">
<meta property="fb:pages" content="1385972475008109">
<meta property="fb:pages" content="1393145820955433">
<meta property="fb:pages" content="1392525091017947">
<meta property="fb:pages" content="1377375672536508">
<meta property="fb:pages" content="597649656980361">
<meta property="fb:pages" content="515940788518481">
<meta property="fb:pages" content="638808226173999">
<meta property="fb:pages" content="676108209113864">
<meta property="fb:pages" content="1401582656769398">
<meta property="fb:pages" content="1399655283631249">
<meta property="fb:pages" content="1468426270039345">
<meta property="fb:pages" content="1421865521394325">
<meta property="fb:pages" content="1474801576076481">
<meta property="fb:pages" content="216299671901966">
<meta property="fb:pages" content="672130512828289">
<meta property="fb:pages" content="827887027227641">
<meta property="fb:pages" content="682975038431191">
<meta property="fb:pages" content="1399191543678416">
<meta property="fb:pages" content="547819275316498">
<meta property="fb:pages" content="268788526614771">
<meta property="fb:pages" content="592758124134638">
<meta property="fb:pages" content="562246977216877">
<meta property="fb:pages" content="287098264771048">
<meta property="fb:pages" content="1109249149124372">
<meta property="fb:pages" content="636962073132407">
<meta property="fb:pages" content="1607045872928088">
<meta property="fb:pages" content="847736411993251">
<meta property="fb:pages" content="533605593496437">
<meta property="fb:pages" content="1076031099184010">
<meta property="fb:pages" content="334839183521804">
<meta property="fb:pages" content="1009957799073579">
<meta property="fb:pages" content="1003120093120327">
<meta property="fb:pages" content="1671577759825164">
<meta property="fb:pages" content="322518931425785">
<meta property="fb:pages" content="1719696458291599">
<meta property="fb:pages" content="531612907033297">
<meta property="fb:pages" content="495452747319946">
<meta property="fb:pages" content="1587073968261411">
<meta property="fb:pages" content="286667641715989">
<meta property="fb:pages" content="181282148968628">
<meta property="fb:pages" content="210769099450478">

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NRXCWXT');</script>

<script src="https://socialcanvas-cdn.kargo.com/js/rh.min.js"></script>
<meta name="google-site-verification" content="xrMjzwfhOwMxUz94SZEc5xbkhFJMV1LIaj2jgakxMFE" /> 
<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/apple-touch-icon-57x57-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="/apple-touch-icon-60x60-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/apple-touch-icon-72x72-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="/apple-touch-icon-76x76-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/apple-touch-icon-114x114-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="/apple-touch-icon-120x120-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/apple-touch-icon-144x144-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="/apple-touch-icon-152x152-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="180x180" href="/apple-touch-icon-180x180-precomposed.png" />
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
<link rel="icon" type="image/png" href="/favicon-128.png" sizes="128x128" />
<link rel="icon" type="image/png" href="/favicon-196x196.png" sizes="196x196" />
<meta name="application-name" content="The Spun" />
<meta name="msapplication-TileColor" content="#ffffff" />
<meta name="msapplication-square70x70logo" content="mstile-70x70.png" />
<meta name="msapplication-TileImage" content="mstile-144x144.png" />
<meta name="msapplication-square150x150logo" content="mstile-150x150.png" />
<meta name="msapplication-wide310x150logo" content="mstile-310x150.png" />
<meta name="msapplication-square310x310logo" content="mstile-310x310.png" />

<link rel="icon" href="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-100x100.png" sizes="32x32" />
<link rel="icon" href="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-300x300.png" />
<meta name="msapplication-TileImage" content="https://thespun.com/wp-content/uploads/2016/08/SPUNsquarePhosphateSolid-300x300.png" />
<style type="text/css" id="wp-custom-css">
			p { 
font-size:17px; 
}
#smartbanner-ad {
	-webkit-transform: translateZ(0);
	-webkit-backface-visibility: hidden;
	-webkit-perspective: 1000;
	left: 0;
	position: fixed;
	text-align: center;
	bottom: 0px;
	width: 100%;
	z-index:999;
}		</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>
<body class="post-template-default single single-post postid-1244584 single-format-standard content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden no-js"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><div class="mai-aec mai-aec-header-before"><div class="wrap"><p><script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script><script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
apstag.init({
    pubID: 'a85c3013-4cc8-497d-94e9-389ed61613f5',
    adServer: 'googletag',
    simplerGPT: true
});
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.cmd.push(function() {
var adunit1 = googletag.sizeMapping().
addSize([1075, 0], [[300, 600], [300, 250]]). //desktop
addSize([1024, 0], [[160, 600]]). //tablet
addSize([0, 0], [[0, 0]]). //mobile
build();
var adunit2 = googletag.sizeMapping().
addSize([2000, 0], [[728, 90], [320, 50], [1, 1]]). //desktopbigger
addSize([1025, 0], [[728, 90], [320, 50], [1, 1]]). //desktop
addSize([768, 0], [[728, 90], [320, 50], [1, 1]]). //iPad
addSize([481, 0], [[320, 50]]). //tablet
addSize([0, 0], [[320, 50], [1, 1]]). //mobile
build();
var adunit3 = googletag.sizeMapping().
addSize([1075, 0], [[300, 600], [300, 250]]). //desktop
addSize([1024, 0], [[160, 600]]). //tablet
addSize([0, 0], [[0, 0]]). //mobile
build();
var adunit4 = googletag.sizeMapping().
addSize([1024, 0], [[1, 1], [320, 50]]). //desktop
addSize([768, 0], [[1, 1], [320, 50]]). //tablet
addSize([0, 0], [[1, 1], [300, 250], [320, 50]]). //mobile
build();
var adunit5 = googletag.sizeMapping().
addSize([1024, 0], [[1, 1], [320, 50], [300, 250]]). //desktop
addSize([768, 0], [[1, 1], [320, 50], [300, 250]]). //tablet
addSize([0, 0], [[1, 1], [300, 250], [320, 50]]). //mobile
build();
var adunit6 = googletag.sizeMapping().
addSize([1025, 0], [[320, 50], [700, 250]]). //desktop
addSize([768, 0], [[300, 250], [320, 50]]). //tablet
addSize([0, 0], [[1, 1], [300, 250], [320, 50]]). //mobile
build();
var adunit7 = googletag.sizeMapping().
addSize([1075, 0], [[728, 90]]). //desktop
addSize([1024, 0], [[320, 50]]). //iPadPro
addSize([800, 0], [[728, 90]]). //tablet
addSize([0, 0], [[320, 50]]). //mobile
build();
 if (window.innerWidth > 1023) { googletag.defineSlot('/81469499/HeaderRightRailTop', [[300, 250], [300, 600], [160, 600]], 'div-gpt-ad-1469714874611-1').defineSizeMapping(adunit1).addService(googletag.pubads()); }
 if (document.getElementById("smartbanner-ad")) { googletag.defineSlot('/81469499/HeaderSmartBanner', [[1, 1], [320, 50], [728, 90]], 'div-gpt-ad-1469714874611-2').defineSizeMapping(adunit2).addService(googletag.pubads()); }
 if (window.innerWidth > 1023) { googletag.defineSlot('/81469499/HeaderRightRail2', [[300, 250], [300, 600], [160, 600]], 'div-gpt-ad-1469714874611-3').defineSizeMapping(adunit3).addService(googletag.pubads()); }
 if (document.getElementById("paragraph-3-ad")) { googletag.defineSlot('/81469499/HeaderAfter3Paragraphs', [[600, 300], [300, 250], [320, 50], [1, 1]], 'div-gpt-ad-1469714874611-4').defineSizeMapping(adunit4).addService(googletag.pubads()); }
 if (document.getElementById("before-entry-ad")) { googletag.defineSlot('/81469499/HeaderBeforeContent', [[1, 1], [300, 250], [320, 50]], 'div-gpt-ad-1469714874611-5').defineSizeMapping(adunit5).addService(googletag.pubads()); }
 if (document.getElementById("paragraph-6-ad")) { googletag.defineSlot('/81469499/HeaderAfter7Paragraphs', [[300, 250], [1, 1], [320, 50]], 'div-gpt-ad-1469714874611-6').defineSizeMapping(adunit6).addService(googletag.pubads()); }
 if (document.getElementById("after-entry-content-ad")) { googletag.defineSlot('/81469499/HeaderAfterContent', [[320, 50], [1, 1], [728, 90]], 'div-gpt-ad-1469714874611-7').defineSizeMapping(adunit7).addService(googletag.pubads()); }
googletag.pubads().setTargeting("url", "cleveland-browns");
googletag.pubads().disableInitialLoad();
googletag.pubads().enableSingleRequest(); googletag.enableServices(); });
googletag.cmd.push(function(){ 
 apstag.fetchBids({ 
 timeout: 2000 }, 
   function(bids) {
     apstag.setDisplayBids(); 
     googletag.pubads().refresh();
 }); 
});
</script><script defer src="https://users.api.jeeng.com/users/domains/5OW6r3jJ2L/sdk/configs"></script><script defer src="https://sdk.jeeng.com/v3.js"></script></p>
</div></div><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://thespun.com/">The Spun</a></p><p class="site-description">What&#039;s trending in the sports world today.</p></div><div class="widget-area header-widget-area"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><nav class="nav-header"><ul id="menu-primary-nav" class="menu genesis-nav-menu js-superfish"><li id="menu-item-333904" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-333904"><a href="https://thespun.com/category/nfl"><span>NFL</span></a></li>
<li id="menu-item-333901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333901"><a href="https://thespun.com/category/college-football"><span>College Football</span></a></li>
<li id="menu-item-333903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333903"><a href="https://thespun.com/category/nba"><span>NBA</span></a></li>
<li id="menu-item-333908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333908"><a href="https://thespun.com/category/college-hoops"><span>College Hoops</span></a></li>
<li id="menu-item-451373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-451373"><a href="https://thespun.com/category/more/interviews"><span>Interviews</span></a></li>
<li id="menu-item-1182759" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1182759"><a href="https://si.com"><span>SI.com</span></a></li>
<li id="menu-item-327514" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-327514"><a href="https://thespun.com/what-is-college-spun"><span>About</span></a></li>
</ul></nav></div></section>
</div></div></header> <div id="search-box" style="display:none;">
<div class="wrap">
<p class="search-desc">Search The Spun ...</p>
<form class="search-form" method="get" action="https://thespun.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://thespun.com/?s={s}"></form> <a class="search-close" href="#"><span class="screen-reader-text">Close</span><span class="fa fa-times" aria-hidden="true"></span></a>
</div>
</div>
<div class="site-inner"><div class="mai-aec mai-aec-header-after"><div class="wrap"><div id="smartbanner-ad">
<div id="div-gpt-ad-1469714874611-2"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-2'); });
</script></div>
</div>
</div></div><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-1244584 post type-post status-publish format-standard has-post-thumbnail category-cleveland-browns category-top-stories tag-baker-mayfield entry" aria-label="Browns, Baker Mayfield&#8217;s Reps Met At The NFL Combine"><header class="entry-header"><p class="entry-meta"><span class="entry-meta-left"><time class="entry-time">March 3, 2022 @ 5:11pm</time><span class="entry-author"> » <a href="https://thespun.com/author/matthladik" class="entry-author-link" rel="author"><span class="entry-author-name">Matt Hladik</span></a></span></span></p><h1 class="entry-title">Browns, Baker Mayfield&#8217;s Reps Met At The NFL Combine</h1>
</header><div class="entry-content"><div class="featured-image" style="max-width:800px;text-align:center;margin:0 auto;"><img width="775" height="465" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20775%20465'%3E%3C/svg%3E" class="attachment-featured size-featured wp-post-image" alt="Cleveland Browns quarterback Baker Mayfield." 0="itemprop" 1="image" data-lazy-srcset="https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-775x465.jpg 775w, https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-380x228.jpg 380w" data-lazy-sizes="(max-width: 775px) 100vw, 775px" data-lazy-src="https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-775x465.jpg" /><noscript><img width="775" height="465" src="https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-775x465.jpg" class="attachment-featured size-featured wp-post-image" alt="Cleveland Browns quarterback Baker Mayfield." 0="itemprop" 1="image" srcset="https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-775x465.jpg 775w, https://thespun.com/wp-content/uploads/2021/11/GettyImages-1356090378-380x228.jpg 380w" sizes="(max-width: 775px) 100vw, 775px" /></noscript><span class="caption">BALTIMORE, MARYLAND - NOVEMBER 28: Baker Mayfield #6 of the Cleveland Browns passes during a game against the Baltimore Ravens at M&amp;T Bank Stadium on November 28, 2021 in Baltimore, Maryland. (Photo by Patrick Smith/Getty Images)</span></div><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p>According to a new report, the Cleveland Browns confirmed their commitment to <a href="https://thespun.com/tag/baker-mayfield">Baker Mayfield</a> during a meeting with the quarterback&rsquo;s reps on Thursday.</p><div class="mai-aec mai-aec-entry-content"><div class="wrap"><div id="before-entry-ad">
<div id="after-entry-content-ad">
<div id="div-gpt-ad-1469714874611-5"><script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-5'); });
</script></div>
</div>
</div>
</div></div>
<p>The two sides met at the NFL scouting combine as scheduled today, <a href="https://www.cleveland.com/browns/2022/03/the-browns-and-baker-mayfields-reps-met-as-scheduled-at-the-combine-reinforced-plans-to-start-him-in-22-and-not-replace-him-with-a-veteran.html">per Cleveland.com&rsquo;s</a> Mary Kay Cabot. The Browns reiterated during the conversation that Mayfield will be the team&rsquo;s starter in 2022 and that they will not be pursuing other options.</p>
<p>&ldquo;The two sides also agreed that he&rsquo;ll head into the final season of his contract &mdash; the fifth-year option year at $18.86 million &mdash; without an extension but with a chance to prove he&rsquo;s the long-term answer,&rdquo; Cabot wrote.</p>
<p>This news echoes what general manager Andrew Berry and head coach Kevin Stefanski <a href="https://thespun.com/nfl/afc-north/cleveland-browns/kevin-stefanski-has-1-word-response-to-baker-mayfield-question">had to say</a> this week. Both said Mayfield would start next season and Berry expressed confidence in the former No. 1 pick&rsquo;s ability to show improved form after an injury-riddled 2021 season.</p><div class="mai-aec mai-aec-entry-content"><div class="wrap"><div id="paragraph-3-ad">
<div id="div-gpt-ad-1469714874611-4"><script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-4'); });
</script></div>
</div>
</div></div>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">The <a href="https://twitter.com/hashtag/Browns?src=hash&amp;ref_src=twsrc%5Etfw">#Browns</a> and Baker Mayfield's reps met at the <a href="https://twitter.com/hashtag/NFLCombine?src=hash&amp;ref_src=twsrc%5Etfw">#NFLCombine</a> as scheduled on Thursday, and reinforced the Browns plans to start him in '22 and not replace him with a veteran, sources tell clevelanddotcom <a href="https://t.co/7BuV3XWktb">https://t.co/7BuV3XWktb</a></p>
<p>&mdash; Mary Kay Cabot (@MaryKayCabot) <a href="https://twitter.com/MaryKayCabot/status/1499498076817473536?ref_src=twsrc%5Etfw">March 3, 2022</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>It&rsquo;s noteworthy that Cleveland is backing Mayfield in this manner because the Browns have been rumored to be considering trades for veteran quarterbacks.</p><div class="mai-aec mai-aec-entry-content"><div class="wrap"><div id="paragraph-6-ad">
<div id="div-gpt-ad-1469714874611-6"><script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-6'); });
</script></div>
</div>
</div></div>
<p>Mayfield is currently rehabbing from shoulder surgery to repair a torn labrum. This was one of two issues in Mayfield&rsquo;s non-throwing arm which affected his play in 2021.</p>
<p>One year after posting the best stats of his career (3,563 passing yards, 26 touchdowns and only eight interceptions) and leading the Browns to an 11-5 record and the team&rsquo;s first playoff win in 26 years, Mayfield threw for only 3,010 yards and posted a 17-13 touchdown-to-interception ratio last fall.</p>
<script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link data-minify="1" rel='stylesheet' id='college-spun-css'  href='https://thespun.com/wp-content/cache/min/1/wp-content/themes/collegespun/style-5d005c448b860c4bfcfd84c75fb15e77.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://thespun.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.8' type='text/css' media='all' /><link rel='stylesheet' id='cspun-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400italic%2C700%2C900&#038;ver=3.0.34&#038;display=swap' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='font-awesome-css'  href='https://thespun.com/wp-content/cache/min/1/font-awesome/4.6.2/css/font-awesome.min-1365f7632c20556688c027d02ede560a.css' type='text/css' media='all' /></noscript><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6e673cd5ffaa81cf","token":"64bbe375419d47fab08c564d810010e9","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body></html>
<div class="mai-aec mai-aec-after-entry-content"><div class="wrap"><div id="div-gpt-ad-1469714874611-7"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-7'); });
</script></div>
<div class="OUTBRAIN" data-src="https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine" data-widget-id="AR_3"></div>
<p><script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script></p>
</div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://thespun.com/category/nfl/afc-north/cleveland-browns" rel="category tag">Cleveland Browns</a>, <a href="https://thespun.com/category/more/top-stories" rel="category tag">Top Stories</a></span> <span class="entry-tags">Tagged With: <a href="https://thespun.com/tag/baker-mayfield" rel="tag">Baker Mayfield</a></span></p></footer></article><section class="author-box"><img alt="" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20200%20200'%3E%3C/svg%3E" class="avatar avatar-200" height="200" width="200" data-lazy-src="https://thespun.com/wp-content/uploads/2016/07/tux-150x150.jpg" /><noscript><img alt="" src="https://thespun.com/wp-content/uploads/2016/07/tux-150x150.jpg" class="avatar avatar-200" height="200" width="200"/></noscript><div class="author-box-content-wrap"><h4 class="author-box-title">About <span itemprop="name">Matt Hladik</span></h4><div class="author-box-content" itemprop="description"><p>Matt is an Editor at The Spun Media.</p>
<div class="author-social"><a target="_blank" class="author-icon author-twitter" href="https://twitter.com/matthladik919"><span class="fa fa-twitter"></span></a><a target="_blank" class="author-icon author-facebook" href="https://www.facebook.com/MattHladikCS/?fref=ts"><span class="fa fa-facebook"></span></a></div></div></div></section></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Search The Spun Here</h3>
<form class="search-form" method="get" action="https://thespun.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-2">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://thespun.com/?s={s}"></form></div></section>
<section id="cspun_popular_posts-2" class="widget widget_cspun_popular_posts"><div class="widget-wrap"><h3 class="widgettitle widget-title">What&#8217;s Trending</h3>
<ul"><li><a class="swPopularity" href="https://thespun.com/nfl/nfc-east/new-york-giants/dez-bryant-thinks-1-nfl-player-should-want-to-be-traded">Dez Bryant Thinks 1 NFL Player Should Want To Be Traded</a></li><li><a class="swPopularity" href="https://thespun.com/nba/celtics-offer-injury-update-on-jaylen-brown">Celtics Offer Injury Update On Jaylen Brown</a></li><li><a class="swPopularity" href="https://thespun.com/more/top-stories/kansas-city-chiefs-likely-to-francise-tag-1-player">Kansas City Chiefs &#8220;Likely&#8221; To Francise Tag 1 Player</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/afc-north/cleveland-browns/longtime-college-football-nfl-assistant-has-died-at-73">Longtime College Football, NFL Assistant Has Died At 73</a></li><li><a class="swPopularity" href="https://thespun.com/more/top-stories/nebraska-takes-down-no-23-ohio-state-in-major-upset-fans-react">Nebraska Takes Down No. 23 Ohio State In Major Upset: Fans React</a></li></ul></div></section>
<section id="mai_aec_widget_a-3" class="widget widget_mai_aec_widget_a"><div class="widget-wrap"><div class="mai-aec mai-aec-widget-b"><div id="div-gpt-ad-1469714874611-1"><script type='text/javascript'>if (window.innerWidth > 1023) {
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-1'); });
}</script></div>
</div></div></section>
<section id="featured-post-6" class="widget featured-content featuredpost"><div class="widget-wrap"><h3 class="widgettitle widget-title">More Trending</h3>
<article class="post-1244356 post type-post status-publish format-standard has-post-thumbnail category-kansas-city-chiefs category-trending tag-jackson-mahomes tag-patrick-mahomes entry" aria-label="Patrick Mahomes&#8217; Brother Says Media Is &#8216;Destroying&#8217; His Life"><a href="https://thespun.com/nfl/afc-west/kansas-city-chiefs/patrick-mahomes-brother-says-media-is-destroying-his-life" class="alignnone" aria-hidden="true" tabindex="-1"><img width="300" height="177" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20177'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Patrick Mahomes&#039; brother, Jackson Mahomes." data-lazy-srcset="https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-300x177.png 300w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-1024x603.png 1024w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-150x88.png 150w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-768x452.png 768w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-1536x904.png 1536w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM.png 1716w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-300x177.png" /><noscript><img width="300" height="177" src="https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-300x177.png" class="entry-image attachment-post" alt="Patrick Mahomes&#039; brother, Jackson Mahomes." srcset="https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-300x177.png 300w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-1024x603.png 1024w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-150x88.png 150w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-768x452.png 768w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM-1536x904.png 1536w, https://thespun.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-17-at-9.52.36-PM.png 1716w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://thespun.com/nfl/afc-west/kansas-city-chiefs/patrick-mahomes-brother-says-media-is-destroying-his-life">Patrick Mahomes&#8217; Brother Says Media Is &#8216;Destroying&#8217; His Life</a></h4></header></article><article class="post-1244183 post type-post status-publish format-standard has-post-thumbnail category-top-stories category-trending entry" aria-label="Lia Thomas Opens Up About Her Controversial Season"><a href="https://thespun.com/more/top-stories/lia-thomas-opens-up-about-her-controversial-season" class="alignnone" aria-hidden="true" tabindex="-1"><img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Lia Thomas at the NCAA championships." data-lazy-srcset="https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-300x200.jpg 300w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-1024x682.jpg 1024w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-150x100.jpg 150w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-768x512.jpg 768w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-1536x1023.jpg 1536w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670.jpg 2048w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-300x200.jpg" /><noscript><img width="300" height="200" src="https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-300x200.jpg" class="entry-image attachment-post" alt="Lia Thomas at the NCAA championships." srcset="https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-300x200.jpg 300w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-1024x682.jpg 1024w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-150x100.jpg 150w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-768x512.jpg 768w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670-1536x1023.jpg 1536w, https://thespun.com/wp-content/uploads/2022/01/GettyImages-1363656670.jpg 2048w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://thespun.com/more/top-stories/lia-thomas-opens-up-about-her-controversial-season">Lia Thomas Opens Up About Her Controversial Season</a></h4></header></article></div></section>
<section id="mai_aec_widget_b-2" class="widget widget_mai_aec_widget_b"><div class="widget-wrap"><div class="mai-aec mai-aec-widget-b"><div id="div-gpt-ad-1469714874611-3"><script type='text/javascript'>if (window.innerWidth > 1023) {
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469714874611-3'); });
}</script></div>
</div></div></section>
<section id="cspun_popular_posts-3" class="widget widget_cspun_popular_posts"><div class="widget-wrap"><h3 class="widgettitle widget-title">More Trending</h3>
<ul"><li><a class="swPopularity" href="https://thespun.com/more/top-stories/college-basketball-fans-arent-buying-coach-ks-latest-claim">College Basketball Fans Aren&#8217;t Buying Coach K&#8217;s Latest Claim</a></li><li><a class="swPopularity" href="https://thespun.com/nba/los-angeles-lakers/colin-cowherd-has-message-for-russell-westbrook">Colin Cowherd Has Harsh Message For Russell Westbrook</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/afc-west/los-angeles-chargers/chargers-release-statement-on-former-ohio-state-stars-death">Chargers Release Statement On Former Ohio State Star&#8217;s Death</a></li><li><a class="swPopularity" href="https://thespun.com/more/top-stories/bradley-beal-reveals-which-way-hes-leaning-in-free-agency">Bradley Beal Reveals Which Way He&#8217;s Leaning In Free Agency</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/afc-west/kansas-city-chiefs/patrick-mahomes-brother-says-media-is-destroying-his-life">Patrick Mahomes&#8217; Brother Says Media Is &#8216;Destroying&#8217; His Life</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/nfc-west/seattle-seahawks/nfl-world-reacts-to-latest-russell-wilson-trade-speculation">Russell Wilson Trade Speculation Still Going: NFL World Reacts</a></li><li><a class="swPopularity" href="https://thespun.com/nfl/afc-west/kansas-city-chiefs/jackson-mahomes-speaks-out-to-media-nfl-world-reacts">Jackson Mahomes Speaks Out To Media: NFL World Reacts</a></li><li><a class="swPopularity" href="https://thespun.com/college-football/deion-sanders-opens-up-about-viral-incident-with-reporter-last-season">Deion Sanders Opens Up About Viral Incident With Reporter</a></li></ul></div></section>
<section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><h3 class="widgettitle widget-title">Sign Up For Our Emails</h3>
<div class="textwidget custom-html-widget"><script src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-mailmunch-site-id="568577" async="async"></script>
<div class="mailmunch-forms-widget-716347"></div>
<div class="mailmunch-forms-widget-716356"></div>
<div class="mailmunch-forms-widget-716390"></div>
<div class="mailmunch-forms-widget-716407"></div>
<div class="mailmunch-forms-widget-716411"></div>
<div class="mailmunch-forms-widget-716418"></div>
<div class="mailmunch-forms-widget-716434"></div>
<div class="mailmunch-forms-widget-716442"></div>
<div class="mailmunch-forms-widget-716446"></div>
<div class="mailmunch-forms-widget-716447"></div>
<div class="mailmunch-forms-widget-716450"></div>
<div class="mailmunch-forms-widget-716452"></div>
<div class="mailmunch-forms-widget-716453"></div>
<div class="mailmunch-forms-widget-716454"></div>
<div class="mailmunch-forms-widget-716437"></div></div></div></section>
</aside></div></div><nav class="nav-secondary" aria-label="Secondary"><div class="wrap"><ul id="menu-footer-nav" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-198365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198365"><a href="https://thespun.com/privacy-policy"><span>Privacy Policy / Terms Of Use</span></a></li>
<li id="menu-item-345159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-345159"><a href="https://thespun.com/coverage-by-team"><span>Coverage By Team</span></a></li>
</ul></div></nav><footer class="site-footer"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2022 <a href="https://thespun.com">The Spun</a> · All Rights Reserved · Powered by <a href="https://bizbudding.com/showcase/thespun/" target="_blank" rel="nofollow noopener">BizBudding Inc.</a></p></div></footer></div><nav id="side-menu" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><button class="menu-close" role="button" aria-pressed="false"><span class="fa fa-times" aria-hidden="true"></span> Close</button><form class="search-form" method="get" action="https://thespun.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-3">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-3" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://thespun.com/?s={s}"></form><div class="menu-primary-nav-container"><ul id="menu-primary-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-333904"><a href="https://thespun.com/category/nfl">NFL</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333901"><a href="https://thespun.com/category/college-football">College Football</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333903"><a href="https://thespun.com/category/nba">NBA</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333908"><a href="https://thespun.com/category/college-hoops">College Hoops</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-451373"><a href="https://thespun.com/category/more/interviews">Interviews</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1182759"><a href="https://si.com">SI.com</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-327514"><a href="https://thespun.com/what-is-college-spun">About</a></li>
<li class="menu-item search"><a id="search-btn" class="search-btn"><span class="screen-reader-text">Search</span><span class="fa fa-search" aria-hidden="true"></span></a></li></ul></div><div class="menu-footer-nav-container"><ul id="menu-footer-nav-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-198365"><a href="https://thespun.com/privacy-policy">Privacy Policy / Terms Of Use</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-345159"><a href="https://thespun.com/coverage-by-team">Coverage By Team</a></li>
</ul></div></nav><div id="side-posts"><button class="menu-close" role="button" aria-pressed="false"><span class="fa fa-times" aria-hidden="true"></span> Close</button><ul><li class="side-posts-date">March 03, 2022</li><li class="side-post"><div class="side-post-time">3 mins ago</div><div class="side-post-title"><a href="https://thespun.com/nfl/afc-north/cleveland-browns/browns-baker-mayfields-reps-met-at-the-nfl-combine" title="Browns, Baker Mayfield&#8217;s Reps Met At The NFL Combine">Browns, Baker Mayfield&#8217;s Reps Met At The NFL Combine</a></div></li><li class="side-post"><div class="side-post-time">14 mins ago</div><div class="side-post-title"><a href="https://thespun.com/big-12/oklahoma-sooners/college-football-reporter-stepping-away-from-journalism" title="Longtime College Football Reporter Stepping Away From Journalism">Longtime College Football Reporter Stepping Away From Journalism</a></div></li><li class="side-post"><div class="side-post-time">23 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/golf/pga-tour-star-jason-day-announces-his-mom-has-died" title="PGA Tour Star Jason Day Announces His Mom Has Died">PGA Tour Star Jason Day Announces His Mom Has Died</a></div></li><li class="side-post"><div class="side-post-time">26 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/tennis/roger-federer-unlikely-to-play-wimbledon-fans-react" title="Roger Federer Unlikely To Play Wimbledon: Fans React">Roger Federer Unlikely To Play Wimbledon: Fans React</a></div></li><li class="side-post"><div class="side-post-time">28 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/top-stories/kyrie-irving-has-hired-a-notable-new-agent" title="Kyrie Irving Has Hired A Notable New Agent">Kyrie Irving Has Hired A Notable New Agent</a></div></li><li class="side-post"><div class="side-post-time">29 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/top-stories/espn-computers-prediction-for-duke-vs-north-carolina" title="ESPN Computer&#8217;s Prediction For Duke vs. North Carolina">ESPN Computer&#8217;s Prediction For Duke vs. North Carolina</a></div></li><li class="side-post"><div class="side-post-time">29 mins ago</div><div class="side-post-title"><a href="https://thespun.com/acc/duke-blue-devils/coach-k-has-surprising-admission-on-retirement-plans" title="Coach K Has Surprising Admission On Retirement Plans">Coach K Has Surprising Admission On Retirement Plans</a></div></li><li class="side-post"><div class="side-post-time">33 mins ago</div><div class="side-post-title"><a href="https://thespun.com/nba/brooklyn-nets/nba-world-reacts-to-kyrie-irving-hires-stepmom-as-agent" title="Kyrie Irving Hires Stepmom As Agent: NBA World Reacts">Kyrie Irving Hires Stepmom As Agent: NBA World Reacts</a></div></li><li class="side-post"><div class="side-post-time">39 mins ago</div><div class="side-post-title"><a href="https://thespun.com/nfl/malik-willis-official-wonderlic-score-is-reportedly-out" title="Malik Willis&#8217; Official Wonderlic Score Is Reportedly Out">Malik Willis&#8217; Official Wonderlic Score Is Reportedly Out</a></div></li><li class="side-post"><div class="side-post-time">50 mins ago</div><div class="side-post-title"><a href="https://thespun.com/nfl/nfc-north/green-bay-packers/report-where-things-stand-with-aaron-rodgers-packers" title="Report: Where Things Stand With Aaron Rodgers, Packers">Report: Where Things Stand With Aaron Rodgers, Packers</a></div></li><li class="side-post"><div class="side-post-time">51 mins ago</div><div class="side-post-title"><a href="https://thespun.com/more/tennis/roger-federers-coach-shares-a-crushing-health-update" title="Roger Federer&#8217;s Coach Shares A Crushing Health Update">Roger Federer&#8217;s Coach Shares A Crushing Health Update</a></div></li><li class="side-post"><div class="side-post-time">59 mins ago</div><div class="side-post-title"><a href="https://thespun.com/big-ten/ohio-state-buckeyes/analyst-names-most-heated-rivalry-in-college-sports" title="Analyst Names Most &#8220;Heated&#8221; Rivalry In College Sports">Analyst Names Most &#8220;Heated&#8221; Rivalry In College Sports</a></div></li></ul></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NRXCWXT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>


<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "31752891" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=31752891&cv=2.0&cj=1" />
</noscript>

<center><button onclick="window._sp_ccpa.loadPrivacyManagerModal(6304, '5e0b5fc44dbd9d1ec085ecb3')">California Privacy Rights</button>
</center><script type='text/javascript' src='https://thespun.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://thespun.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script type='text/javascript' src='https://thespun.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3' id='skip-links-js'></script>
<script type='text/javascript' src='https://thespun.com/wp-content/themes/collegespun/assets/js/jquery.sidr.min.js?ver=2.2.1' id='sidr-js'></script>
<script type='text/javascript' id='cspun-global-js-extra'>
/* <![CDATA[ */
var cspun_global_vars = {"side_posts_count":"148","side_posts_title":"New Articles","single_post":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thespun.com/wp-content/themes/collegespun/assets/js/global.js?ver=1.0.0' id='cspun-global-js'></script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://thespun.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script><noscript><link data-minify="1" rel='stylesheet' id='college-spun-css'  href='https://thespun.com/wp-content/cache/min/1/wp-content/themes/collegespun/style-5d005c448b860c4bfcfd84c75fb15e77.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://thespun.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.8' type='text/css' media='all' /><link rel='stylesheet' id='cspun-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C400italic%2C700%2C900&#038;ver=3.0.34&#038;display=swap' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='font-awesome-css'  href='https://thespun.com/wp-content/cache/min/1/font-awesome/4.6.2/css/font-awesome.min-1365f7632c20556688c027d02ede560a.css' type='text/css' media='all' /></noscript></body></html>
